• Составить программу вывода значений функции y = ( x3 + 5x -8) / (x – 7) ** отрезке [ -...

0 голосов
26 просмотров

• Составить программу вывода значений функции y = ( x3 + 5x -8) / (x – 7) на отрезке [ - 10; 13] c шагом 0,5


Информатика (49 баллов) | 26 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

Const x0=-10; xk=13; h=0.5;
var x,y:real; i,n:integer;
begin
n:=round((xk-x0)/h)+1;
x:=x0-h;
for i:=1 to n do
 begin
 x:=x+h;
 if x<>7
  then begin y:=(x*x*x+5*x-8)/(x-7); writeln(x:5:1,'  ',y:8:3); end
  else writeln(x:5:1,'  функция не определена');
 end;
end.

Результат (для h=1.0):
-10.0    62.235
 -9.0    48.875
 -8.0    37.333
 -7.0    27.571
 -6.0    19.538
 -5.0    13.167
 -4.0     8.364
 -3.0     5.000
 -2.0     2.889
 -1.0     1.750
  0.0     1.143
  1.0     0.333
  2.0    -2.000
  3.0    -8.500
  4.0   -25.333
  5.0   -71.000
  6.0  -238.000
  7.0  функция не определена
  8.0   544.000
  9.0   383.000
 10.0   347.333
 11.0   344.500
 12.0   356.000
 13.0   375.667

(194k баллов)
0 голосов

- 1 0 П0 3 ИП0 x^y ИП0 5 * + 8 - ИП0 7 - / С/П ИП0 0 , 5 + П0 1 3 - x<0 32 БП 04 С/П