Составить программу в паскалеВвести число. Если оно четное и положительное, разделить его...

0 голосов
45 просмотров

Составить программу в паскале
Ввести число. Если оно четное и положительное, разделить его на 4, если четное и отрицательное- умножить на 5, если нечетное - возвести в квадрат.


Информатика (12 баллов) | 45 просмотров
Дан 1 ответ
0 голосов

Var n:longint;
      c:real;
begin
  write ('N = ');
  readln(n);
  if (n mod 2 = 0) and (n>0)  then c:=n/4 else
    if (n mod 2 = 0) and (n<0) then c:=n*5 else<br>      if (n mod  = 1) then c:=sqr(n);
  write (c:0:2);
end.

(2.8k баллов)