Паскаль. Напишите программу, которая по последней цифре числа определяет последнюю цифру...

0 голосов
54 просмотров

Паскаль. Напишите программу, которая по последней цифре числа определяет последнюю цифру квадрата этого числа


Информатика (34 баллов) | 54 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

Var a, b: longint;
begin
write ('введите число -> ');
readln (a);
a:=a mod 10;
b:=(a*a) mod 10;
writeln ('последняя цифра квадрата числа -> ',b);
end.

0 голосов

Var i: Integer;
begin
 write('Число: ');
 readLn(i);
 i := i mod 10;
 writeLn('Цифра квадрата = ',
 sqr(i) mod 10);
end.

(8.0k баллов)