Напишите программу винипух съедает 100 грамм варенья первый день, во второй день еще 100...

0 голосов
72 просмотров

Напишите программу винипух съедает 100 грамм варенья первый день, во второй день еще 100 грамм варенья, в третий день 200 грамм варенья, в каждый последующий день он съедает кол-во варенья равное сумме количества варенья в 2 прошедших днях. За сколько дней он съест К грамм варенья


image

Информатика (152 баллов) | 72 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Program Vinni;
var x,x1,x2,x3,y,sum:integer; 
begin
writeln('введите кол-во грамм');
readln(x);if x<100 then writeln('меншье чем за час :)');<br>if x=100 then writeln('столько он скушает за 1 день');
if (x>100) and (x<200) then writeln('от 1 до 2 дней не включая их');<br>if x=200 then writeln('за два первых дня он скушает столько!)');
if x>200 then begin
x1:=100;
x2:=100;
x3:=200;
y:=2;
sum:=200;
repeat
if sum<=x then begin  x2:=x1+x3; sum:=sum+x2; y:=y+1; end;<br>if sum<=x then begin  x1:=x2+x3; y:=y+1; sum:=sum+x1; end;<br>if sum<=x then begin  x3:=x1+x2; sum:=sum+x3; y:=y+1; end;<br>until (sum>=x) or (sum>=x) or (sum>=x);writeln(y);
end;
end.

(1.8k баллов)
0

Чего-то ты меня запутал, первое решение гораздо лучше))

0

если я беру 400 грамм

0

то первое решение будет 4 дня а тут 3

0

4 ближе к 3

0

ой

0

4 ближе к правильному

0

нет, смотрите. 1-й день 100, 2-й день 100, 3-й день 200. А за первые три дня - 400.

0

введите кол-во грамм
400
3

0

3 верный ответ

0

всё понял