1)Напишите программу, которая определяет, верно ли, что введенное число состоит из...

0 голосов
57 просмотров

1)Напишите программу, которая определяет, верно ли, что введенное число состоит из одинаковых цифр(например, 222)
2)Напишите программу, которая определяет, верно ли, что введеное число содержит две одинаковые цифры, стоящие рядом (например, 221)
Паскаль


Информатика (17 баллов) | 57 просмотров
Дан 1 ответ
0 голосов

1)
#include
#include

using namespace std;

int main() {
 int a;
 cin >> a;
 int d = a%10;
 string s = "yes";
 while(abs(a) > 0) {
   if(a%10 != d) {
     s = "no";
     break;
   }
   a/=10;
  }
  cout << s << endl;<br>}
2)
#include
#include

using namespace std;

int main() {
 int a;
 cin >> a;
 int d = a%10;
 a/=10;
 string s = "no";
 while(abs(a) > 0) {
  if(a%10 == d) {
    s = "yes";
    break;
  }
  d = a%10;
  a/=10;
  }
  cout << s << endl;<br>}

(4.6k баллов)