Даны два целых числа a и b. напишите программу, которая находит произведение целых чисел от a до b, произведение которых на 6 оканчивается на 2 оброзец 1 10 ввод 14 вывод
Видимо, вот так: 1*6(-), 2*6(+), 3*6(-), 4*6(-), 5*6(-), 6*6(-), 7*6(+), 8*6(-), 9*6(-), 10*6(-). Итого: 2*7=14. У составителя задачи фантазия богатая. Можно позавидовать ).
Var a,b,p,i: integer; begin write ('Введите 2 числа: '); readln (a,b); p:=1; for i:=a to b do if (i*6) mod 10 =2 then p:=p*i; writeln (p); end. --------------Результат--------------- Введите 2 числа: 1 10 14