Напишите программу, которая вычисляет следующее значение. По теореме Пифагора, в...

0 голосов
43 просмотров

Напишите программу, которая вычисляет следующее значение. По теореме Пифагора, в прямоугольном треугольнике соотношение сторон C2=A2+B2. Если A=3, B=2, каково значение C? в Pascal ABC


Информатика (19 баллов) | 43 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Program Teorema_P;
var    A, B, C: real;
begin
     writeln ('Введите значение первого катета:');
     readln (A);
     writeln ('Введите значение второго катета:');
     readln (B);
     C:=sqrt(A*A + B*B);
     writeln ('Катет А = ', A, ', катет В = ', B, ', гипотенуза С = ', C:5:3);
end.


image
(100 баллов)
0

А где A2,B2,C2 вставлять нужно?

0

program TEOREMA_P;
var A2,B2,C2:real;
begin
writeln(3);
readln(A2);
writeln(2);
readln(B2);
C2:=sqrt(A2+B2);
writeln('A2=6,B2=4');
end.