Написать программу в Паскале

0 голосов
54 просмотров

Написать программу в Паскале


image

Информатика (208 баллов) | 54 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var x,y:real; i:integer;
begin
write('x = ');
readln(x);
y:=0;
if x>0
 then for i:=1 to 10 do y:=y+1/((2*i-1)*x)
 else if x<0 then for i:=1 to 10 do y:=y+1/(2*i*x);<br>writeln('y = ',y:5:3);
end.

Пример:
x = -2
y = -0.732

(194k баллов)
0

А откуда мы берём эти 5 значений х?Вот вопрос мне такой задали

0

Значение x должно вводиться с клавиатуры. Чтобы получить 5 результатов, программу нужно запустить 5 раз.