Написать программу замены в двумерном массиве его элементов ** их модули

0 голосов
32 просмотров

Написать программу замены в двумерном массиве его элементов на их модули


Информатика (14 баллов) | 32 просмотров
Дан 1 ответ
0 голосов

{ массив 2 на 4}
const  a:array[1..2,1..4] of integer = (
  (1,2,3,4),
  (-1,-2,-3,-4)  );
var  i,j:integer;
begin
for i := 1 to 2 do
for j:= 1 to 4 do
  a[i,j]:=abs(a[i,j]);

for i := 1 to 2 do
begin
  for j:= 1 to 4 do
    write(a[i,j],' ');
  writeln;
end;
  
end.

(444 баллов)