Написать программы к следующим задачам: а) Вводятся три числа. Вывести ** экран сумму з...

0 голосов
39 просмотров

Написать программы к следующим задачам:
а) Вводятся три числа. Вывести на экран сумму з трех чисел
б)Человек делает в магазине покупки. Определите сколько денег у него останется
после покупки в магазине перчаток стоимостью А руб., портфеля стоимостью B руб. и галстука стоимостью D руб. Все исходные данные задаются с клавиатуры. КТО ПОМОЖЕТ В ПАСКАЛЕ 89 БАЛОВ


Информатика (64 баллов) | 39 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Program RLN; 
var a,b,c,d:real; 
begin 
writeln ('Введите значения трёх чисел:'); 
read (a); 
read (b); 
read (c); 
d:=a+b+c; 
write ('Сумма этих трёх чисел = '); 
write (d); 
end.

(121 баллов)
0

Тоже ошибка

0

Внутренняя ошибка компилятора в модуле Compiler.Compile[Compiler] :'System.OutOfMemoryException: Выдано исключение типа "System.OutOfMemoryException".
в GPPGParserScanner.GPPGParser.DoAction(Int32 action)
в QUT.Gppg.ShiftReduceParser`2.Reduce(Int32 ruleNumber)
в QUT.Gppg.ShiftReduceParser`2.Parse()
в PascalABCCompiler.PascalABCNewParser.GPPGParserHelper.Parse(Stri

0

У меня работает, может у вас что-то не так?

0

Сейчас еще раз попробую,что то не получается

0

а 2 задачу?

0

program RLN;
var a,b,c,d,e,k:real;
begin
writeln ('Сколько денег у человека перед покупками?');
read (c);
writeln ('Сколько стоят перчатки?');
read (a);
writeln ('Сколько стоит портфель?');
read (b);
writeln ('Сколько стоит галстук?');
read (d);
e:=a+b+d;
k:=c-e;
write ('Осталось денег: ');
write (k);
end.

0

Тоже рабочая. Если снова будут проблемы с программой - неполадки с вашей стороны.