Написать программу, которая находит решения уравнения ax^3+bx=0 для любых заданных...

0 голосов
53 просмотров

Написать программу, которая находит решения уравнения ax^3+bx=0 для любых заданных значений a и b.
Пожалуйста, на паскале


Информатика (168 баллов) | 53 просмотров
0

Точно x в кубе? Там не квадрат?

0

в кубе

Дан 1 ответ
0 голосов

Var a,b:integer;
x,c:real;
begin
read(a,b);
if ((-b)/a)>=0 then begin 
      x:=sqrt((-b)/a); 
      c:=-x; 
   writeln('x=',0); 
   writeln('x=',x); 
   writeln('x=',c);
end
else 
   writeln('x=',0);
end.

(172 баллов)