Написать программу,которая проверяет,есть ли во введённом с клавиатуры массиве элементы с...

0 голосов
102 просмотров

Написать программу,которая проверяет,есть ли во введённом с клавиатуры массиве элементы с одинаковым значением


Информатика (350 баллов) | 102 просмотров
Дан 1 ответ
0 голосов
Правильный ответ
// PascalABC.NET 3.2, сборка 1379 от 21.01.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ReadArrInteger('Вводите:',ReadInteger('n='));
  if a.Count>a.ToHashSet.Count then
    Writeln('Есть одинаковые элементы')
  else Writeln('Все элементы различны')
end.

Примеры
n= 4
Вводите: 4 2 5 2
Есть одинаковые элементы

n= 4
Вводите: 5 8 -3 0
Все элементы различны
(150k баллов)