Задача по теме рандомиз и сранд: Составьте программу ** языке С++ для решения одного из...

0 голосов
34 просмотров

Задача по теме рандомиз и сранд:
Составьте программу на языке С++ для решения одного из вариантов заданий. Программа должна иметь пользовательское меню, которое позволяет: заполнить массив и при этом вывести его на экран, выполнить операции над массивом и просмотреть результаты, закрыть программу.

Вариант 6: Одномерный массив из 16 элементов случайным образом заполняется целыми числами из диапазона [-240..180]. Найти сумму четных отрицательных и сумму нечетных положительных элементов массива.
Начал писать:
#include
#include
#include
#include
#include
#include

int main (void)
{
int x[16];
int t;
randomize();x=random(180) - 240;
// for (t = 0; t < 16; ++t) scanf("%d ", x[t]);
for (t = 0; t < 16; ++t) printf("%d ", x[t]);
return 0 ;
}

Пишет ошибку:
12 14 E:\1 Ó×ÅÁÀ\5ñåìåñòð\ïðîãðàììû\ïð4.1.cpp [Error] 'randomize' was not declared in this scope
13 13 E:\1 Ó×ÅÁÀ\5ñåìåñòð\ïðîãðàììû\ïð4.1.cpp [Error] 'random' was not declared in this scope
Не могу дальше этого места пройти. Можно при помощи srand, если вам будет проще...


Информатика (286 баллов) | 34 просмотров
Дан 1 ответ
0 голосов

//////////////////////////////


image
image
(1.3k баллов)