Задан массив А[1..5]. составьте программу, которая выводит ** экран элементы массива в...

0 голосов
74 просмотров

Задан массив А[1..5]. составьте программу, которая выводит на экран элементы массива в обратном порядке.


Информатика (130 баллов) | 74 просмотров
Дано ответов: 2
0 голосов
Правильный ответ
// PascalABC.NET 3.2, сборка 1370 от 24.12.2016
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(5,-99,99); a.Println;
  a.Reverse.Println;
end.

Пример
-80 64 42 -50 16
16 -50 42 64 -80

(150k баллов)
0 голосов

Const n=5; 
var a:array[1..n] of integer;
i:integer; 
begin
Randomize;
writeln('Массив A:');
for i:=1 to n do
 begin
 a[i]:=random(51);
 write(a[i]:4);
 end;
writeln;
writeln('Массив A в обратном порядке:');
for i:=n downto 1 do write(a[i]:4);
writeln;
end.

Пример:
Массив A:
 37 39 41 9 25
Массив A в обратном порядке:
 25 9 41 39 37

(194k баллов)
0

у тебя там она правильно написана

0

ну запятые не где не забыл>?