Напишите программу, которая по введенным с клавиатуры числам a, f, g и h будет вычислять...

0 голосов
149 просмотров

Напишите программу, которая по введенным с клавиатуры числам a, f, g и h будет вычислять значения коэффициентов a,b и c, а также значение дискриминанта D, решать это квадратное уравнение и выдавать результаты его решения.


image

Информатика (44 баллов) | 149 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

Var a,b,c,e,f,g,h,w,d,x1,x2:real;
begin
writeln('e, f, g, h, w:');
readln(e,f,g,h,w);
a:=sqrt(abs((w+h)/e));
b:=sqr(e+f);
c:=sqrt(abs(g-2*e))-sin(f);
writeln('a = ',a,' b = ',b,' c = ',c);
d:=b*b-4*a*c;
writeln('d = ',d);
if d>0
 then 
  begin 
  x1:=(-b+sqrt(d))/(2*a);
  x2:=(-b-sqrt(d))/(2*a);
  writeln('x1 = ',x1,'  x2 = ',x2);
  end
 else if d=0 then begin x1:=-b/(2*a); writeln('x = ',x1); end
             else writeln('Корней нет');
end.

Пример:
e, f, g, h, w:
8 -5 2 3 5
a = 1 b = 9 c = 2.7827331121108
d = 69.8690675515568
x1 = -0.320614053728802  x2 = -8.6793859462712

(194k баллов)
0 голосов
var 
  a,b,c,d,e,f,g,h,w,x1,x2: real;
begin
  write ('Введите e: '); readln (e);
  write ('Введите f: '); readln (f);
  write ('Введите g: '); readln (g);
  write ('Введите h: '); readln (h);
  write ('Введите w: '); readln (w);
  a:=sqrt(abs((w+h)/e));
  b:=(e+f)*(e+f);
  c:=sqrt(abs(g-2*e))-sin(f);
  d:=b*b-4*a*c;
  writeln;  
  writeln ('a = ',a);
  writeln ('b = ',b);
  writeln ('c = ',c:9:5);
  writeln ('d = ',d:9:4);
  if d>=0 
    then begin
      x1:=(-1*b+sqrt(d))/(2*a);
      x2:=(-1*b-sqrt(d))/(2*a); 
      writeln ('x1 = ',x1:10:6);  
      writeln ('x2 = ',x2:9:5);end
    else
      writeln ('Уравнение не имеет корней');    
end.
---------------------------------------
Введите e: 8
Введите f: -5
Введите g: 2
Введите h: 3
Введите w: 5

a = 1
b = 9
c =   2.78273
d =   69.8691
x1 =  -0.320614
x2 =  -8.67939

(3.5k баллов)