3. Написать программу ** языке JAVA, которая по заданному номеру единицы измерения (1 –...

0 голосов
78 просмотров

3. Написать программу на языке JAVA, которая по заданному номеру единицы измерения (1 – килограмм, 2 – миллиграмм, 3 – грамм, 4 – тонна, 5 – центнер) и массы M выдавала бы соответствующее значение массы в килограммах.помогите пожалуйстаа


Информатика (15 баллов) | 78 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Import java.util.*;


public class zadacha
{

public static void main(String[]args)

{

cout("Введите номер ед.изм: ");

@SuppressWarnings("resource") Scanner cin = new Scanner (System.in);
double v=cin.nextInt();

cout("Введите массу в указанной ед.изм: ");
double m=cin.nextDouble();

if (v==1) {
  print(m);
 }

else if (v==2) {
  print(m/st(6));
 }

else if (v==3) {
  print(m/st(3));
  }

else if (v==4) {
  print(m*st(3));
 }

else if (v==5) {
  print(m*st(2));
}

}

public static void cout (String text)
{
 System.out.print(text);
}
public static void print(double printer)
{
 System.out.print(printer);
}

public static int st(int t)
{
t=(int) Math.pow(10, t); return t;
}

}

(235 баллов)
0

ну да

0

спасибо огромноее)) а подскажите ещё,пожалуйста,как изменить,чтобы оператор switch был