ПОЖАЛУЙСТА!ПОМОГИТЕ!СРОЧНО!Решить задачи ** турбопаскале:1.Дано натуральное число Найти...

0 голосов
41 просмотров
ПОЖАЛУЙСТА!ПОМОГИТЕ!СРОЧНО!
Решить задачи на турбопаскале:

1.Дано натуральное число Найти сумму и произведение первых двух чисел.
2.Дано n-значное натуральное число. Правда ли что квадрат произведения цифр числа равняется кубу суммы цифр числа.
3.Составить программу, которая печатает таблицу умножения и сложения натуральных чисел в десятичной системе счисления.

Информатика (34 баллов) | 41 просмотров
0

Что-то я не совсем понял с 1-м Может, первых двух [I]цифр[/I]?

0

Да,да, ошиблась случайно,первых двух цифр.

Дан 1 ответ
0 голосов
Правильный ответ

Program  Kasyanova98_1;
uses crt;
var n,nt,p:integer;
  begin
  writeln('***   Alphaues is thinking...   ***');
  write('Ok, введите натуральное число N = ');
  readln(n);
  nt:=n;
  while nt>=10 do
    begin
      p:=nt;
      nt:= nt div 10;
    end;
  writeln('Cумма первых двух цифр числа ',n,' равна ',(p div 10)+(p mod 10));
  writeln('Произведение первых двух цифр числа ',n,' равно ',(p div 10)*(p mod 10));
end.

Program  Kasyanova98_2;
uses crt;
var n,nt,sum,kw,temp:integer;
  begin
  writeln('***   Alphaues is thinking...   ***');
  write('Ok, введите натуральное число N = ');
  readln(n);
  nt:=n;
  sum:=0;
  kw:=1;
  while nt>=1 do
    begin
    temp:=nt mod 10;
    sum := sum + temp;
    kw:=kw * temp;
    nt := nt div 10;
  end;
  if kw*kw=sum*sum*sum then
      writeln('Квадрат произведения цифр числа ',n,' равняется кубу суммы его цифр')
    else
writeln('Квадрат произведения цифр числа ',n,' НЕ равняется кубу суммы его цифр');
end.

Program Kasyanova98_3.1;
uses crt;
const n=10;
var
  x,y:integer;
begin
  writeln('********************************************************');
  writeln('*                   ТАБЛИЦА УМНОЖЕНИЯ                  *');
  writeln('********************************************************');
  write('*    * ');
  for y:=1 to n do
    begin
      write(y:2);
      if y      else      writeln(' * ');
    end;
  writeln('********************************************************');
  for x:=1 to n do
    begin
      write('* ',x:2, ' * ');
      for y:=1 to n do
         begin
          write(x*y:2);
          if y        end;
        if x*y<100 then writeln(' * ')<br>                   else writeln('* ');
        if x<10 then writeln('+------------------------------------------------------+')<br>                else writeln('********************************************************');
    end;
end.

Program Kasyanova98_3.2;
uses crt;
const n=10;
var
  x,y:integer;
begin
  writeln('********************************************************');
  writeln('*                   ТАБЛИЦА СЛОЖЕНИЯ                   *');
  writeln('********************************************************');
  write('*    * ');
  for y:=1 to n do
    begin
      write(y:2);
      if y      else      writeln(' * ');
    end;
  writeln('********************************************************');
  for x:=1 to n do
    begin
      write('* ',x:2, ' * ');
      for y:=1 to n do
         begin
          write(x+y:2);
          if y        end;
        if x+y<100 then writeln(' * ')<br>                   else writeln('* ');
        if x<10 then writeln('+------------------------------------------------------+')<br>                else writeln('********************************************************');
    end;
end.

(52.6k баллов)