1)Написать ** языке Паскаль программу ввода четырёх целых чисел и вычисления их среднего...

0 голосов
60 просмотров

1)Написать на языке Паскаль программу ввода четырёх целых чисел и вычисления их среднего арифметического.
2)Вводятся величины X,Y целого типа. Написать программу для обмена значений величин. Необходимо использовать вспомогательную величину Т. Протестировать программу для X=5 и Y=-11.
3)Написать программу для вычисления дискриминанта d квадратного уравнения ax2 + bx + c = 0.
4)Дан размер файла в байтах. Используя операцию деления нацело, найти количество полных килобайтов, которые занимает данный файл (1 килобайт = 1024 байта).
5)Дано двузначное число. Найти сумму и произведение его цифр.
Помогите, пожалуйста.
Ничего не понимаю по этому паскалю


Информатика (46 баллов) | 60 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

1) Сейчас сделаю остальное.
Program arifm;Var a, b, c, d, ar:real;beginwriteln('Введите первое число');readln(a);writeln('Введите второе число');readln(b);writeln('Введите третье число');readln(c);writeln('Введите четвертое число');readln(d);ar:=(a+b+c+d)/4;writeln('Ответ:',ar);end.

(172 баллов)
0

Program arifm;
Var a, b, c, d, ar:real;
begin
writeln('Введите первое число');
readln(a);
writeln('Введите второе число');
readln(b);
writeln('Введите третье число');
readln(c);
writeln('Введите четвертое число');
readln(d);
ar:=(a+b+c+d)/4;
writeln('Ответ:',ar);
end.

0

Это второе

0

program xy;
var x,y,T:integer;
begin
writeln('Введите первое число');
read(x);
writeln('Введите второе число');
read(y);
T:=x;
x:=y;
y:=T;
writeln('после обмена');
writeln('x=',x,' y=',y);
end.

0

Это третье

0

Program xy;
Var a, b, c, d:real;
begin
writeln('Введите первое число');
readln(a);
writeln('Введите второе число');
readln(b);
writeln('Введите третье число');
readln(c);
d:=sqr(b)-4*a*c;
if d>0 then writeln('Уравнение имеет два корня');
if d<0 then writeln('Уравнение не имеет корней');<br>if d=0 then writeln('Уравнение имеет один корень');
end.

0

Это четвертое

0

Program bkb;
Var b, kb:real;
begin
writeln('Введите количество байтов');
readln(b);
kb:=1024/b;
writeln('Ответ:',kb:30:0);
end.