Задачи нужно решить ** языке Паскаль. Изучаем string. 1.Дана строка. Написать программу,...

0 голосов
42 просмотров

Задачи нужно решить на языке Паскаль. Изучаем string.
1.Дана строка. Написать программу, выводящую сумму порядковых номеров заданного символа.
2.Дано предложение состоящее из английских заглавных букв. В предложении только одно слово в котором 3 буквы. Вам нужно написать программу которая найдет это слово и выведет его в файл.


Информатика (1.3k баллов) | 42 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

//PascalABC.NET 3.2 сборка 1318

Var
  s:string;
  c:char;
  sum,i:integer;
begin
readln(s);
readln(c);
for i:=1 to length(s) do
if s[i]=c then sum+=i;
writeln(sum);
end.

Пример ввода:
konichiva
i
Пример вывода:
11

//2
Var
  f:text;
  s:string;
  i:integer;
begin
readln(s);
var ars:=s.Split;
i:=0;
while ars[i].Length<>3 do
inc(i);
assign(f,'output.txt');
rewrite(f);
write(f,ars[i]);
close(f);
end.
  
Пример ввода:
ARK DRIVE FINISH
Пример вывода в файл output.txt:
ARK

(38.6k баллов)