Написать программу, Паскаль. Дано натуральное число N. Вычислить S = 1! + 2! +3! + ... +...

0 голосов
23 просмотров

Написать программу, Паскаль. Дано натуральное число N. Вычислить S = 1! + 2! +3! + ... + n! (n>=1) Решить через repeat (с постусловием)


Информатика (2.0k баллов) | 23 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var S,f:longint; n,a:byte;
begin
s:=0;a:=1;f:=1;
readln(n);
repeat
f:=f*a;
s:=s+f;
inc(a);
until a>n;
writeln(s);
end.
Вроде так

(2.3k баллов)