Срочно! Помогите написать программу Паскаль, которая ввод данных в одномерный...

0 голосов
53 просмотров

Срочно! Помогите написать программу Паскаль, которая ввод данных в одномерный целочисленный массив осуществляет посредством цикла WHILE...DO, а вывод -REPEAT...UNTIL (в скобках указана размерность массива):
1.заменить каждый отрицательный элемент произведением всех ненулевых элементов массива (8);


Информатика (17 баллов) | 53 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Const
    N = 8;

var
    a: array[1..N] of integer;
    p: integer;
    i: byte;

begin
    writeln('Введите массив из ', N, ' элементов');
    i := 0;
    p := 1;
    
    while i < n do
    begin
        i := i + 1;
        read(a[i]);
        if a[i] <> 0 then p := p * a[i];
    end;
    
    writeln('Отредактированный массив');
    i := 0;
    repeat
        i := i + 1;
        if a[i] < 0 then a[i] := p;
        write(a[i], ' ');
    until i >= n;
end.

(55.0k баллов)