Решите в Паскаль ABC Составить программу, решающую следующую задачу: Вы покупаете товар,...

0 голосов
71 просмотров

Решите в Паскаль ABC
Составить программу, решающую следующую задачу: Вы покупаете товар, и у Вас
имеются монеты номиналом 1, 2, 5, 10 рублей. Наберите необходимую сумму товара в
N рублей так, чтобы она состояла из минимального
количества монет.


Информатика (25 баллов) | 71 просмотров
Дан 1 ответ
0 голосов

Var a: integer;
begin
     readln(a);
     writeln(a div 10, 'x10, ', a mod 10 div 5, 'x5, ', a mod 10 mod 5 div 2, 'x2, ', a mod 50 mod 5 mod 2 div 1, 'x1');
end.

(16.9k баллов)