Написать программу ** Pascal, используя рекурсию: Дан набор символов, оканчивающихся...

0 голосов
56 просмотров

Написать программу на Pascal, используя рекурсию:
Дан набор символов, оканчивающихся пробелом (короче это слово), Вывести символы в обратном порядке, используя рекурсию.


Информатика (54 баллов) | 56 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

Var s: string;
procedure PrintChar(s:string;n:integer);
begin
    if s[n]<>' '
     then begin PrintChar(s,n+1); write(s[n]); end;
end;
begin
    write('Введите слово: ');
    readln(s);
    PrintChar(s,1);
end.

Пример:
Введите слово: телефон 
нофелет

(194k баллов)
0 голосов

Program pos;
var
    s: string;
    l: integer;
procedure PrintChar(n: integer);
var
    sub: string;
begin
    sub := Copy(s, n, 1);
    write(sub);
    if n <> 1 then
        PrintChar(n - 1);
end;
begin
    write('Введите слово: ');
    readln(s);
    l := Length(s);
    PrintChar(l);
end.

(7.2k баллов)