Как составить программу поиска минимума среди значений косинусов компонент вектора x...

0 голосов
49 просмотров

Как составить программу поиска минимума среди значений косинусов компонент вектора x размерностью n ?


Информатика (25 баллов) | 49 просмотров
0

нода найти минимум

0

надо*

0

да

0

да

0

саму программу как составить?

Дан 1 ответ
0 голосов
Правильный ответ
// PascalABC.NET 3.2, сборка 1385 от 14.02.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var n:=ReadInteger('n=');
  var a:=ReadArrReal('Введите компоненты:',n);
  Writeln('Минимальный косинус равен ',a.Select(x->cos(x)).Min:0:5)
end.
(150k баллов)
0

что значит select&

0

А есть еще другой способ написания этой программы?

0

можете показать еще другой способ

0

ну ладно спасибо большое)