Написать программу для Pascal. Вот условие. Надеюсь ** помощь.

0 голосов
41 просмотров

Написать программу для Pascal. Вот условие. Надеюсь на помощь.


image

Информатика (23 баллов) | 41 просмотров
0

Не совсем понял задание, переведи на русский если не сложно

0

Дан текст в виде одного слова. Составить программу которая проверяет является частью заданного слова слово "рак". Ответом должно быть да или нет

Дано ответов: 2
0 голосов
Правильный ответ

Var s:array[1..100]:string;
      i:integer;
begin
 write('введите слово);
 read(s);
 for i:=1 to lenght(s) do 
   if s[i]+s[i+1]+s[i+2] = 'рак' then 
  writeln('da')   else  writeln('net')
end.

(136 баллов)
0 голосов

Program asdasd;
    var s:string;
begin;
    read(s);
    if pos('рак',s) = 0 then write('Нет') else write('Да');
end.

(336 баллов)