Помогите написать программу по информатике (** паскале) ** перевод из десятичной системы...

0 голосов
40 просмотров

Помогите написать программу по информатике (на паскале) на перевод из десятичной системы счисления в двоичную.


Информатика (15 баллов) | 40 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Program todec;
uses crt;
function detob(x:integer):string;
var s:string;
begin
s:='';
while x>0 do
begin
s:=chr(ord('0')+x mod 2)+s;
x:=x div 2;
end;
detob:=s;
end;
var a: integer;
begin
clrscr;
writeln('Введите число:');
readln(a);
writeln('Полученное число:',detob(a));
readln;
end.

(149k баллов)