Составить программу ** языке pascal abc. По алгоритму (Алгоритм приложен)

0 голосов
75 просмотров

Составить программу на языке pascal abc. По алгоритму (Алгоритм приложен)


image

Информатика (99 баллов) | 75 просмотров
0

var a,x,y:real;beginend;beginwrite('a, x, y: ');readln(a,x,y);if x=0 then y:=1 else if x>0 then st(a,x,y) else st(1/a,-x,y);writeln('y = ',y);end.

0

дальше, не выходит

0

без beginend;*, но все равно не выходит

Дан 1 ответ
0 голосов
Правильный ответ

Var a,x,y:real;
procedure st(a,x:real; var y:real);
begin

end;
begin
write('a, x, y: ');
readln(a,x,y);
if x=0
 then y:=1
 else if x>0 then st(a,x,y) else st(1/a,-x,y);
writeln('y = ',y);
end.

Пример:
a, x, y: 1 2 3
y = 3

(194k баллов)
0

Благодарю