Напишите программу (pascal) Найти сумму вводимых с клавиатуры чисел, которые...

0 голосов
62 просмотров

Напишите программу (pascal)
Найти сумму вводимых с клавиатуры чисел, которые отрицательные.


Информатика (15 баллов) | 62 просмотров
Дано ответов: 2
0 голосов
Правильный ответ
// PascalABC.NET 3.2, сборка 1385 от 14.02.2017
// Внимание! Если программа не работает, обновите версию!

begin
  Writeln('Сумма отрицательных чисел равна ',
    ReadSeqRealWhile('Ввод завершайте нулём:',x->x<>0).Where(x->x<0).Sum)<br>end.

Пример
Ввод завершайте нулём: 2.5 -4 -6.25 5.143 11 -8 0
Сумма отрицательных чисел равна -18.25

(150k баллов)
0 голосов

Program n1;
var sum,a: integer;
begin
sum:=0;
repeat
readln(a);
if a<0 then sum:=sum+a;<br>until (a=0);
writeln(sum);
end.

(149k баллов)