1. Написать программу, которая выводит ** экран сумму средних арифметических значений...

0 голосов
44 просмотров

1. Написать программу, которая выводит на экран сумму средних арифметических значений двух вещественных массивов из 10 элементов.
2. Написать прогрумму,которая выводит на экран, разность значений двух вещественных массивов из 10 элементов.


Информатика (47 баллов) | 44 просмотров
Дан 1 ответ
0 голосов

Я так понимаю, что "значение массива" - это сумма его элементов. Если это так, то вот решение:

1)
Var a,b:array[1..10] of real;
s,k:real; i:integer;
Begin
 wtiteln('Init A:')
 for i:=1 to 10 do
   begin
    readln(k);
    a[i]=k;
   end;
 wtiteln('Init B:')
 for i:=1 to 10 do
   begin
    readln(k);
    b[i]=k;
   end;
 s:=0;
 k:=0;
 for i:=1 to 10 do
   k:=k+a[i];
 k:=k/10;
 for i:= to 10 do
   s:=s+b[i];
 s:=(s/10)+k;
 writeln(s);
End.

2)
Var a,b:array[1..10] of real;
r,k:real, i:integer;
Begin
 writeln('Init A:");
 for i:=1 to 10 do
   begin
    readln(k);
    a[i]:=k;
   end;
 writeln('Init B:");
 for i:=1 to 10 do
   begin
    readln(k);
    b[i]:=k;
   end;
 r:=0
 k:=0;
 for i:=1 to 10 do
   k:=k+a[i];
 for i:=1 to 10 do
   r:=r+b[i];
 r:=r-k;
 writeln(r);
End.

(472 баллов)