Надо написать программу ** паскале, которая будет удалять из числа цифры введённые с...

0 голосов
61 просмотров

Надо написать программу на паскале, которая будет удалять из числа цифры введённые с клавиатуры.
A= 12322
B= 2
C=13
СРОЧНО
надо написать программу, которая будет удалять из числа цифры введенные с
клавиатуры
если вам не в падлу, можете менее мудрено написать?


Информатика (12 баллов) | 61 просмотров
0

Из какого числа?

0

из числа "а"

Дан 1 ответ
0 голосов

Var
a:string[10];
b:char;
j,i:integer;
begin
readln(a);
readln(b);
for i:=1 to 10 do
begin
for j:=1 to 10 do
if a[j]=b then delete(a,j,1);
end;
writeln(a);
end.

(1.9k баллов)