Напишите программу, в которой пользователь вводит 5-тизначное число, а программа выводит...

0 голосов
76 просмотров

Напишите программу, в которой пользователь вводит 5-тизначное число, а программа выводит 5-тизначное число-перевертыш.
на языке пасхаль


Информатика (15 баллов) | 76 просмотров
0

Паскаль!

0

Столько версий уже появилось! И Паскаль=, и Паскаль DEF, и Пасхаль. Интересно - какая будет следующей?

0

//Pashal 3.2beginwrite (readstring('Введите число: ').Inverse);end.

Дано ответов: 2
0 голосов
Правильный ответ

Var a,a1,a2,a3,a4,a5,b:integer;
begin
write('a = ');
readln(a);
a1:=a div 10000;
a2:=a div 1000 mod 10;
a3:=a div 100 mod 10;
a4:=a mod 100 div 10;
a5:=a mod 10;
b:=a5*10000+a4*1000+a3*100+a2*10+a1;
writeln('b = ',b);
end.

Пример:
a = 13524
b = 42531

(194k баллов)
0 голосов

Так как язык программироваия ты не написал, дам ответ на Си++, в данном примере от чистого Си отличается только вводом выводом (cin,cout-scanf,printf)
Решение:
#include "stdafx.h"
#include
using namespase std;
int main()
{
setlocale(0,"");
int A[5];
cout<<"Введите пятизначное число, разделяя каждую цифру пробелом"<<endl;<br>for(int i=0;i<5;i++)<br>{
cin>>A[i];
}
cout<<"Перевёрнутое число:"<<endl;<br>for(int i=4;i>=0;i--)
{
cout<<A[i];<br>}
return 0;
}

(1.8k баллов)
0

блинн, я же там подписал пасхаль

0

program _perevert_;
var a,b,c,d,e,y:integer;
begin
writeln('Введите пятизначное число');
readln(a);
b:= a mod 10;
c:=(a div 10) mod 10;
d:= a div 100;
e:=
y:=
writeln('ответик ' ,b,c,d,);
readln;
end.
там у меня с тремя сходиться а дальше никак