Помогите написать программу для вычисления примера:Или хотя бы ход решения, какие...

0 голосов
25 просмотров

Помогите написать программу для вычисления примера:
y=cos(v)* \sqrt[3]{1+ sin^{2}(v+a) } ; v=(a+c)/a*c; a= e^{-c} +c; c=2.35

Или хотя бы ход решения, какие операторы использовать и т. п.


Информатика (24 баллов) | 25 просмотров
Дан 1 ответ
0 голосов

Const c = 2.35;
var y,v,a:real;
begin
  a:=exp(-c)+c;
  v:=(a+c)/a*c;
  y:=cos(v*pi/180)*exp(1/3*ln(1+sqr(sin((v+a)*pi/180))));
  writeln ('A = ',a:0:4);
  writeln ('V = ',v:0:4);
  writeln ('Y = ',y:0:4);
end.

(2.8k баллов)
0

блин, а я почти правильно решил, только корень из 3 степени не так написал, поэтому паскаль ошибку выдавал.