Написать программу которая проверяет является ли целое число введённое пользователем...

0 голосов
57 просмотров

Написать программу которая проверяет является ли целое число введённое пользователем простым рекомендуемый вид экрана во время работы программы приведён ниже даны введение выражающие полужирным шрифтом


Информатика (14 баллов) | 57 просмотров
Дан 1 ответ
0 голосов

Вот) Модуль нужен, чтобы упростить проверку)
var
  x, i: integer;

begin
  readln(x);
 
  x := abs(x);
  for i := 2 to x - 1 do
    if x mod i = 0 then
    begin
      writeln('No');
      exit;
    end;
  writeln('Yes');
end.

(16.9k баллов)