Помогите, пожалуйста! Нужно написать программу для Pascal АВС . Программа должна...

0 голосов
44 просмотров

Помогите, пожалуйста! Нужно написать программу для Pascal АВС . Программа должна переводить обыкновенные числа в двоичную систему счисления с использованием массива. Заранее большое спасибо!


Информатика (1.7k баллов) | 44 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

Var
  a:array[1..32] of byte;
  i,n:integer;
begin
  Write('Введите натуральное десятичное число: '); Readln(n);
  i:=1;
  repeat a[i]:=n mod 2; n:=n shr 1; Inc(i) until n=0;
  for i:=i-1 downto 1 do Write(a[i])
end.

Пример
Введите натуральное десятичное число: 513
1000000001

(150k баллов)
0 голосов

Program n1;
var
a: array[1..100] of byte;
n,i,c:integer;
begin
write('введите число: ');
readln(n);
c:= 0;
repeat
c:= c + 1;
a[c]:= n mod 2;
n:= n div 2;
until n = 0;
for i:= c downto 1 do
write(a[i]);
end.

(150k баллов)