Написать программу определения стоимости разговора по телефону с учётом скидки 20%,...

0 голосов
127 просмотров

Написать программу определения стоимости разговора по телефону с учётом скидки 20%, предоставляемой по субботам и воскресеньям. Входные данные: Sm(стоимость минуты разговора), M (число минут), Day (день недели - 1...7). Выходные данные: S (стоимость разговора). Ниже представлен вариант выполнения программы Вычисление стоимости телефонного разговора Введите исходные данные Стоимость минуты разговора, руб. 1 Длительность разговора (целое количество минут) 6 День недели (1-понедельник, ... 7-воскресенье) 7


Информатика (81 баллов) | 127 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var M, Day : integer; Sm, S : real;
begin
writeln('Вычисление стоимости телефонного разговора');
writeln('Введите исходные данные');
write('Стоимость минуты разговора, руб. ');
readln(Sm);
write('Длительность разговора (целое количество минут) ');
readln(M);
write('День недели (1-понедельник, ... 7-воскресенье) ');
readln(Day);
S:=Sm*M;
if (Day=6)or(Day=7)
 then writeln('Стоимость разговора с учетом скидки = ',S*0.8)
 else writeln('Стоимость разговора = ',S);
end.

Пример:
Вычисление стоимости телефонного разговора
Введите исходные данные
Стоимость минуты разговора, руб. 3.2
Длительность разговора (целое количество минут) 6
День недели (1-понедельник, ... 7-воскресенье) 7
Стоимость разговора с учетом скидки = 15.36

(194k баллов)