Напишите программу которая удаляет из заданного текста комбинацию "ем" (земля-планета...

0 голосов
47 просмотров

Напишите программу которая удаляет из заданного текста комбинацию "ем" (земля-планета солнечной системы)


Информатика (33 баллов) | 47 просмотров
Дано ответов: 2
0 голосов
Правильный ответ
// PascalABC.NET 3.2, сборка 1374 от 10.01.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var s:=ReadlnString('>');
  s:=s.Replace('ем',''); s.Println
end.

Пример
> земля- планета солнечной системы
зля- планета солнечной систы
(150k баллов)
0 голосов

// PascalABC.NET (версия 3.2, сборка 1363)

const
  RM = 'ем';
var
  c, n: char;
  seq: boolean := False;
  s: string := 'Земля - планета солнечной системы';
begin
  writeln(s);
  for var i := 1 to (length(s) -1) do
  begin
    c := s[i];
    n := s[i+1];
    if seq = True then
    begin
      seq := False;
      continue;
    end;
    if (c = RM[1]) and (n = RM[2]) then
    begin
      seq := True;
      continue;
    end
    else
    begin
      seq := False;
      write(c);
    end;
  end;
  write(s[length(s)]);
end.

(7.2k баллов)