Дан вектор имеющий n (1<=n<=100)целых элементов. напишите программу которая находит...

0 голосов
54 просмотров

Дан вектор имеющий n (1<=n<=100)целых элементов. напишите программу которая находит среднее арифметическое значение элементов, стоящих на нечётных позициях


Информатика (33 баллов) | 54 просмотров
Дан 1 ответ
0 голосов

#include
#include
using namespace std;

int main() {
    unsigned short int n;
    cout << "n = ";<br>    cin >> n;
    vector a;
    int in,
        avg,
        s = 0,
        c = 0;
    for (int i = 0; i < n; ++i) {
        cout << "a[" << i << "] = ";<br>        cin >> in;
        a.insert(a.end(), in);
        if (i % 2 == 1) {
            s += a.back();
            c++;
        }
    }
    avg = (int) s / c;
    cout << "Среднее арифметическое элементов на нечётных позициях: "<br>         << avg;<br>    return 0;
}

(7.2k баллов)