Напишите программу ** языке программирования (или составьте алгоритм). Подсчитать...

0 голосов
32 просмотров

Напишите программу на языке программирования (или составьте алгоритм). Подсчитать количество простых чисел в одномерном массиве размером N, состоящем из целых чисел, полученных случайным образом.


Информатика (15 баллов) | 32 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

//
Program n1;
function pr(a:longint):boolean;
var i:longint;
begin
if a<2 then pr:=false<br>else
begin
pr:=true;
for i:=2 to round(sqrt(a)) do
if a mod i=0 then pr:=false;
end;
end;
const n=15;
var a:array[1..n] of integer;
i,k:integer;
begin
randomize;
k:=0;
for i:=1 to n do a[i]:=random(100);
writeln('массив: ');
for i:=1 to n do write(a[i],' ');
writeln;
for i:=1 to n do
if pr(a[i]) then k:=k+1;
writeln('кол-во простых чисел: ',k);
end.

(149k баллов)