Составить программу для того, чтобы компьютер, используя генератор случайных чисел,...

0 голосов
59 просмотров

Составить программу для того, чтобы компьютер, используя генератор случайных чисел, записал на экране случайное число, значение которого лежит в пределах от 5 до 6 и имеет 2 знака в дробной части.


Информатика (360 баллов) | 59 просмотров
0

всмысле дробовое число от 5 до 6?

0

так в задании написано, я просто скопировала из задания и сюда добавила

0

окей

0

ты сделаешь ?

0

думаю, да но сейчас другое твое задание сделаю

0

хорошо

0

Я мог бы сделать. Нужно или уже кто-то будет делать?

0

нужно

0

На каком языке-то?

0

паскаль

Дано ответов: 2
0 голосов
Правильный ответ

// PascalABC.NET 3.2, сборка 1381 от 04.02.2017

begin
  Writeln((Random(101)+500)/100)
end.

(150k баллов)
0 голосов

Program sluch_chislo;

uses crt;
var
i : real;
a : string;
begin
clrscr;
Randomize;
writeln ('Для вывода следующего числа нажмите Enter');
writeln ('Для выхода из программы введите 0 и нажмите Enter');

while (true) do
begin
i := random(101)/100+5; //Случайное число от 5.00 до 6.00 включительно
writeln (i:6:2);

readln (a);
if a='0' then exit;
end;

end.

(219 баллов)
0

А кто как говорит... так ведь многие политики до сих пор говорят так: "В двухтысяча шестнадцатом году". После 2000 года многие не перестроились. Правильно ведь говорить "В две тысячи шестнадцатом". И это все понимают. Только не все задумываются, что говорить с "х" - это ошибка.

0

Просто наряду с точными науками нужно больше внимания уделять своему естественному языку, на котором говоришь.

0

Моё решение я давно исправил по вашему замечанию, и интервал там [5;6]. Можете удалять хоть весь сайт. Я не знаю, как там у вас лично полномочия. Но глупо утверждать, что каждый при своём мнении в точных науках. Это глупо, повторю и в десятый раз.

0

Как раз к лингвистам я и апеллирую. Техническая образованность (я имею в виду авторов документации к Паскалю) не снимает ответственности за знание языка общения людей.

0

Пусть скажут своё слово лингвисты. А не модераторы.