ИНФОРМАТИКА 9 КЛАСС! СРОЧНО!!! ЗАДАЧА!! ПОМОГИТЕ!!! Задача. Винни-Пух съел у Кролика в 1...

0 голосов
90 просмотров

ИНФОРМАТИКА 9 КЛАСС! СРОЧНО!!! ЗАДАЧА!! ПОМОГИТЕ!!!
Задача. Винни-Пух съел у Кролика в 1 день 100 г. варенья, во-второй ещё 100 г., в 3-й и все последующие дни он съедал столько, сколько за два предыдущих дня вместе взятых. Написать программу в какой день Винни-Пух съест всё варенье у Кролика, если известно, что у него имеется k килограмм варенья.
Напишете, пожалуйста на языке Паскаль, и если можно еще блок-схему. НО ПРОГРАММА ВАЖНЕЕ!


Информатика (65 баллов) | 90 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var a1,a2,a,s,k:real; n:integer;
begin
a1:=100; a2:=100;
s:=a1+a2;
n:=2;
write('k = ');
readln(k);
k:=k*1000;
while s begin
 a:=a1+a2;
 s:=s+a;
 a1:=a2;
 a2:=a;
 n:=n+1;
 end;
writeln('n = ',n);
end.

Пример:
k = 2
n = 6

(194k баллов)