Написать программу, которая вычисляет, сколько раз введенное с клавиатуры число...

0 голосов
39 просмотров

Написать программу, которая вычисляет, сколько раз введенное с клавиатуры число встречается в массиве. Массив заполняется через random


Информатика (12 баллов) | 39 просмотров
Дан 1 ответ
0 голосов

Var a:array[0..10000] of integer;        k,i,x,n:integer;beginread(n); //n-количество элементов в массивеfor i:=1 to n do 
a[i]:=random (500)+5;
read(x);for i:=1 to n doif a[i]=x then k:=1+k;write(k);end.

(1.6k баллов)
0

var a:array[0..10000] of integer;
k,i,x,n:integer;
begin
read(n);
for i:=1 to n do read(a[i]);
read(x);
for i:=1 to n do
if a[i]=x then
k:=1+k;
write(k);
end.

0

Только вместо read(a[i]), напиши a[i]:=random (500)+5;