Напишите программу, которая получает два целых числа и находит их произведение, не...

0 голосов
164 просмотров

Напишите программу, которая получает два целых числа и находит их произведение, не используя операцию умножения. Учтите, что числа могут быть отрицательными.
На языке СИ


Информатика (31 баллов) | 164 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

//Написано на си/си++
#include #include #include
int main() {setlocale(LC_ALL, "");
int a, b, c = 0;
std::cout << "Введите первое число:"; std::cin >> a;std::cout << "Введите второе число:"; std::cin >> b;
if (b != abs(b)) { a = -a; b = abs(b);//функция которая возвращает модуль переданного числа}
for (int i = 0; i < b; ++i) { c += a;}
std::cout << "num:" << c;<br> system("pause");return 0;}

(664 баллов)
0

Не знаю почему но при копировании все строки съезжают.Извините что это так режет глаза.Просто ставьте "Enter" (если вы знакомы с синтаксисом то это вам не составит большого труда)

0

спасибо:)