Написать программу ** языке Pascal используя операторы цикла. Задача: Задать случайным...

0 голосов
48 просмотров

Написать программу на языке Pascal используя операторы цикла. Задача: Задать случайным образом N (1\leq N \leq 15). Напечатать значение N! = 1*2*3*4*...*N


Информатика (92 баллов) | 48 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Program n1;
var
n, i: integer;
p: real;
begin
randomize;
n:=random(15)+1;
p := 1;
for i := 2 to n do
p := p * i;
writeln(n, '! = ',p);
end.

(149k баллов)
0

"n:=random(15);" разве в этом случае не берётся случайное значение от 0 до 15?

0

да это так, щас исправлю

0

вот формула для рандома для интервала [a;b]: random(b-a+1)+a

0

спасибо