Даны два целых числа a и b. Напишите программу, которая находит среднее арифметическое...

0 голосов
169 просмотров

Даны два целых числа a и b.
Напишите программу, которая находит среднее арифметическое квадратов всех целых чисел от a до b

Входные данные:
В первой строке вводятся два целых числа a и b (a<=b, a,b не больше 100 по модулю)<br>
Выходные данные:
Программа должна вывести одно число - среднее арифметическое квадратов всех целых чисел от a до b (c 2 знаками после запятой)
в c++


Информатика (59 баллов) | 169 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

#include

using namespace std;

int main()
{
    int a,b,n = 0;
    float S = 0;
    cin >> a;
    cin >> b;
    
    for(int i = a; i <= b; i++)<br>    {
         n++;
         S+=i*i;
    }
    S = S/n;
    cout.setf(ios::fixed);
    cout.precision(2);
    cout << "S = " << S << endl;<br>    return 0;
}

(34.0k баллов)