Напишите программу, которая вычисляет факториал натурального числа N ( 1 ≤ N ≤ 10000 ),...

0 голосов
280 просмотров

Напишите программу, которая вычисляет факториал натурального числа N ( 1 ≤ N ≤ 10000 ), сохранив все значащие цифры. Факториалом называется произведение всех натуральных чисел от 1 до N : N ! = 1·2·3... ( N - 1)· N .


Информатика (36 баллов) | 280 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Program n1;
var
n, i: integer;
p: real;
begin
write('Введите n: ');
readln(n);
if (n>=1) and (n<=10000) then<br> begin
p := 1;
for i := 2 to n do
p := p * i;
writeln(n, '! = ', p);
end;
end.

(150k баллов)