Напишите программу, которая определяет, верно ли, что введённое число содержит ровно три...

0 голосов
178 просмотров

Напишите программу, которая определяет, верно ли, что введённое число содержит ровно три одинаковые цифры, а все остальные встречаются только по одному разу (например, как в числе 77237) PascalABC
!решать при помощи while!


Информатика (174 баллов) | 178 просмотров
0

Точно-точно без массивов?))

0

точно точно

0

if или while

Дан 1 ответ
0 голосов
Правильный ответ

Var
A,B0,B1,B2,B3,B4,B5,B6,B7,B8,B9:integer;
Begin
WriteLn('Введите число');
ReadLn(A);
While A>0 do
   Begin
   Case A mod 10 of
   0:B0:=B0+1;
   1:B1:=B1+1;
   2:B2:=B2+1;
   3:B3:=B3+1;
   4:B4:=B4+1;
   5:B5:=B5+1;
   6:B6:=B6+1;
   7:B7:=B7+1;
   8:B8:=B8+1;
   9:B9:=B9+1;
   End;
   A:= A div 10;
   End;
if (B0 = 3)and(B1<2)and(B2<2)and(B3<2)and(B4<2)and(B5<2)and(B6<2)and(B7<2)and(B8<2)and(B9<2)then WriteLn('Верно')<br>else if (B1 = 3)and(B2<2)and(B3<2)and(B4<2)and(B5<2)and(B6<2)and(B7<2)and(B8<2)and(B9<2)and(B0<2)then WriteLn('Верно')<br>else if (B2 = 3)and(B3<2)and(B4<2)and(B5<2)and(B6<2)and(B7<2)and(B8<2)and(B9<2)and(B0<2)and(B1<2)then WriteLn('Верно')<br>else if (B3 = 3)and(B4<2)and(B5<2)and(B6<2)and(B7<2)and(B8<2)and(B9<2)and(B0<2)and(B1<2)and(B2<2)then WriteLn('Верно')<br>else if (B4 = 3)and(B5<2)and(B6<2)and(B7<2)and(B8<2)and(B9<2)and(B0<2)and(B1<2)and(B2<2)and(B3<2)then WriteLn('Верно')<br>else if (B5 = 3)and(B6<2)and(B7<2)and(B8<2)and(B9<2)and(B0<2)and(B1<2)and(B2<2)and(B3<2)and(B4<2)then WriteLn('Верно')<br>else if (B6 = 3)and(B7<2)and(B8<2)and(B9<2)and(B0<2)and(B1<2)and(B2<2)and(B3<2)and(B4<2)and(B5<2)then WriteLn('Верно')<br>else if (B7 = 3)and(B8<2)and(B9<2)and(B0<2)and(B1<2)and(B2<2)and(B3<2)and(B4<2)and(B5<2)and(B6<2)then WriteLn('Верно')<br>else if (B8 = 3)and(B9<2)and(B0<2)and(B1<2)and(B2<2)and(B3<2)and(B4<2)and(B5<2)and(B6<2)and(B7<2)then WriteLn('Верно')<br>else if (B9 = 3)and(B0<2)and(B1<2)and(B2<2)and(B3<2)and(B4<2)and(B5<2)and(B6<2)and(B7<2)and(B8<2)then WriteLn('Верно')<br>else WriteLn('Не верно')
End.

(34.0k баллов)
0

Это что?

0

А теперь скажите, как это надо было решать :D