Pascal помогите с двумя задачами срочно!! 1. составьте программу, вычисляющую сумму...

0 голосов
60 просмотров

Pascal

помогите с двумя задачами срочно!!

1. составьте программу, вычисляющую сумму квадратов всех чисел от 1 до N

2.напишите программу, определяющую сумму всех нечетных чисел от 1 до 99


Информатика (154 баллов) | 60 просмотров
Дано ответов: 2
0 голосов
Правильный ответ
// PascalABC.NET 3.2, сборка 1383 от 09.02.2017
// Внимание! Если программа не работает, обновите версию!

Задача 1
begin
  Writeln('S=',Range(1,ReadInteger('N=')).Sum(x->x*x))
end.

Пример
N= 10
S=385

Задача 2
begin
  Writeln('S=',Range(1,99,2).Sum)
end.

Результат
S=2500
(150k баллов)
0 голосов

1.
var n,i:integer;
begin
readln(n);
for i:=1 to n do writeln(i*i);
end.
2.
var n,i:integer
begin
for i:=1 to 99 do
if i mod 2 = 1 then n+=i;
writeln(n)
end.

(4.0k баллов)