Напишите программу, которая вводила бы целые числа и суммировала их до тех пор, пока...

0 голосов
107 просмотров

Напишите программу, которая вводила бы целые числа и суммировала их до тех пор, пока пользователь не ввел число 0


Информатика (29 баллов) | 107 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var
a,s:integer;
begin
  s:=0;
  repeat
  readln(a);
  s:=s+a;
  until a=0;
  writeln('Сумма чисел: ',s);
end

(6.7k баллов)