Напишите программу, которая считывает из файла строки - каждую строку в отдельную...

0 голосов
107 просмотров

Напишите программу, которая считывает из файла строки - каждую строку в отдельную строковую переменную, затем печатает их и их количество.
Язык С++


Информатика (34.0k баллов) | 107 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Проверял на C++11 - работает

#include
#include
#include
#include

using namespace std;

#define FILENAME "input.txt"

int main() {
    ifstream fin(FILENAME);
    vector lines;
    string s;
    while (getline(fin, s))
        lines.push_back(s);
    cout << "Lines:\n";<br>    for (int i = 0; i < lines.size(); i++)
        cout << lines[i] << endl;    <br>    cout << "Count of lines: " << lines.size() << endl;<br>    return 0;
}

(13.3k баллов)
0

Если не работает, нужно заменить цикл for-auto на обычный

0

Не работает. Пожалуйста, замените сами - не понимаю, как это сделать

0

проверьте, работает ли теперь

0

Еще проверьте, создали вы входной файл в папке с самой программой. И напишите имя входного файла в программе, где указано FILENAME

0

Да, благодарю - всё работает