Составить программу в паскале по блок схеме срочно нужно, помогите пжлст

0 голосов
55 просмотров

Составить программу в паскале по блок схеме
срочно нужно, помогите пжлст


image
image

Информатика (32 баллов) | 55 просмотров
0

На второй фотке, первое действие - это последнее на первой фотке?

0

да

0

Можно увидеть задачку, к которой эта блок-схема?

0

Или просто блок-схему сказали перевести?))

Дан 1 ответ
0 голосов
Правильный ответ

Var
i,N:integer;
a,d,S,x,y,S1:real;
Begin
Write('N = ');ReadLn(N);
Write('x = ');ReadLn(x);
Write('y = ');ReadLn(y);
S:=0;
S1:=0;
a:=5;
d:=1.7;
For i:= 1 to N do
    Begin
    S:=S+a;
    if a>x then
       if a    a:=a+d;
    End;
WriteLn('S = ',S);
WriteLn('S1 = ',S1);
End.

(34.0k баллов)
0

спасибо